04-06 R1 Go Kart - Yamaha R1 Forum: YZF-R1 Forums
04-06 R1 Mechanical Help Mechanical and Critical Issues for the 04-06 R1

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 (permalink) Old 06-15-2019, 07:39 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
04-06 R1 Go Kart

Hey everyone I'm new to this forum but I have some questions I'm a 16 year old kid who is currently in the process of building a gokart with an r1 engine I have acquired for only $450 with $500 worth of extras the guy threw in, one of them being a power commander. Anyways i know there is alot of switches and shit I'm gonna have to bypass as I won't be putting this back in a bike. Can anyone tell me everything I'm gonna need to bypass inorder to get the bike to turn over / start.

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
Sponsored Links
Advertisement
 
post #2 of 24 (permalink) Old 06-16-2019, 07:57 PM
I eat my R1
 
Doppler's Avatar
 
Join Date: Jul 2010
Location: Terra Australis NSW
Posts: 1,367
Hi mate, welcome to the forum. Pretty cool project, especially considering your age. Before you get too into it I trust you are aware that the R1 motor produces significant power especially for a go kart and some of the engineering will not be straight forward as you may think.

Anyway, enough sensible! First question is what have you actually got? Is it a bare motor or do you have a wiring harness as well? If you don't you will need one. Do you have an ECU, radiator and fans, instrument panel, air box and throttle bodies, exhaust headers, other sensors like tip over switch?

If you have the motor from throttle bodies to exhaust as well as a harness and ECU you will be close to at least getting it to run.

Plenty of parts around for that generation so you should be able to get what you don't have without huge $$$'s Maybe add some photos of what you have.
Doppler is offline  
post #3 of 24 (permalink) Old 06-16-2019, 08:22 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by Doppler View Post
Hi mate, welcome to the forum. Pretty cool project, especially considering your age. Before you get too into it I trust you are aware that the R1 motor produces significant power especially for a go kart and some of the engineering will not be straight forward as you may think.



Anyway, enough sensible! First question is what have you actually got? Is it a bare motor or do you have a wiring harness as well? If you don't you will need one. Do you have an ECU, radiator and fans, instrument panel, air box and throttle bodies, exhaust headers, other sensors like tip over switch?



If you have the motor from throttle bodies to exhaust as well as a harness and ECU you will be close to at least getting it to run.



Plenty of parts around for that generation so you should be able to get what you don't have without huge $$$'s Maybe add some photos of what you have.
Hey so yea I'm very aware this is gonna be alot more advanced then let's say a lawn mower engine but I'm ready for the challenge. Anyways so yea I have the complete engine with ecu harness power commander exaust manifold airbox spare parts like extra sprockets and throttle bodies with extra Injectors in them. I don't have the start stop switch or the key ignition switch I did order them both off eBay and in the mean time I did short the ignition wires and for the throttle bodies to calibrate and the cluster to turn on but the light on the power commander didn't turn on so I'm pretty sure the ecu didn't have power. And I'm sure it's because I still have multiple switches to bypass like the clutch switch and the kick stand switch and saftey switches before it will give me spark but I can't find much info online about what I'm trying to accomplish so I came here to ask fellow R1 people about all the wiring I need to bypass to get it to run pretty much and any other things you guys think I should know as I'm not exactly a veteran R1 mechanic.

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
 
post #4 of 24 (permalink) Old 06-16-2019, 08:22 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by Andrew_S View Post
Hey so yea I'm very aware this is gonna be alot more advanced then let's say a lawn mower engine but I'm ready for the challenge. Anyways so yea I have the complete engine with ecu harness power commander exaust manifold airbox spare parts like extra sprockets and throttle bodies with extra Injectors in them. I don't have the start stop switch or the key ignition switch I did order them both off eBay and in the mean time I did short the ignition wires and for the throttle bodies to calibrate and the cluster to turn on but the light on the power commander didn't turn on so I'm pretty sure the ecu didn't have power. And I'm sure it's because I still have multiple switches to bypass like the clutch switch and the kick stand switch and saftey switches before it will give me spark but I can't find much info online about what I'm trying to accomplish so I came here to ask fellow R1 people about all the wiring I need to bypass to get it to run pretty much and any other things you guys think I should know as I'm not exactly a veteran R1 mechanic.

Sent from my SM-G965U using Tapatalk
Here are some pictures of what I'm working with

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #5 of 24 (permalink) Old 06-17-2019, 08:29 PM
I eat my R1
 
Doppler's Avatar
 
Join Date: Jul 2010
Location: Terra Australis NSW
Posts: 1,367
Just checking you are in the US right? Reason is if you have a euro model bike it has an immobiliser and without the key that's paired to the ECU you wont get it to run.

To get the thing going remove the power commander and reinstall it once its running to remove at least one variable. Sounds like you are on the right track considering the sensors/switches. Off the top of my head, one's not on the actual motor include as you said, clutch switch, stand switch (there's a special relay for these that also connects to the neutral switch), tip over switch, air temp sensor (I think it's in the air box on that generation), O2 in exhaust (Maybe not on US model), water temp. Most of the others are on the actual motor and inlet.
Doppler is offline  
post #6 of 24 (permalink) Old 06-18-2019, 02:50 AM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by Doppler View Post
Just checking you are in the US right? Reason is if you have a euro model bike it has an immobiliser and without the key that's paired to the ECU you wont get it to run.



To get the thing going remove the power commander and reinstall it once its running to remove at least one variable. Sounds like you are on the right track considering the sensors/switches. Off the top of my head, one's not on the actual motor include as you said, clutch switch, stand switch (there's a special relay for these that also connects to the neutral switch), tip over switch, air temp sensor (I think it's in the air box on that generation), O2 in exhaust (Maybe not on US model), water temp. Most of the others are on the actual motor and inlet.
Yes I have a us engine so there is no imobilizer but the mail came today and I got the starter switch and I plugged the battery back in and I have the tip over sensor plugged in and when I turn the switch to the on position the cluster turns on and the throttle body calibrates and the power commander light turns on but when I go to crank it over there's no spark. How would I go about bypassing the other sensors and where would the connector be? I feel like my harness is Missing some places a Connector should be but idk


Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #7 of 24 (permalink) Old 06-18-2019, 04:43 PM
I eat my R1
 
andrewstclair's Avatar
 
Join Date: Jan 2012
Location: Vancouver, BC.
Posts: 1,384
Garage
put your volt meter to continuity and check if when the kick stand is "up" if the switch is open or close and bypass it accordingly. do the same for the tip over switch when its pointing the right way. the clutch switch you may want to make functional. some bikes have a rev limit thats lower with the clutch lever in i can't remember if that year is one of them, but i don't think so. you want the sensor not he top of the valve cover plugged in for it to spark and theres another plug near it that is green or something that can accidentally be swapped. go to the mechanical help section and at the top is a stick with the service manuals, download yours and lookup component locations for the sensors and it should give you an idea where on the harness they are connecting. there will be photos of plugs and a lot of useful info that other people aren't going to be able to explain as well as a photo

09 R1 black/gold SOLD

2015 R1M 007
2016 R1 Track
andrewstclair is offline  
post #8 of 24 (permalink) Old 06-18-2019, 07:16 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Does anyone know what these connectors are?

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #9 of 24 (permalink) Old 06-18-2019, 07:23 PM
I eat my R1
 
andrewstclair's Avatar
 
Join Date: Jan 2012
Location: Vancouver, BC.
Posts: 1,384
Garage
Black one looks like fans. The green and white one go around the airbox. If you look at the wire colors and look in the service manual it will make it easier to be certain since quite a few of the plugs are identical
iamzombie likes this.

09 R1 black/gold SOLD

2015 R1M 007
2016 R1 Track
andrewstclair is offline  
post #10 of 24 (permalink) Old 06-26-2019, 04:28 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Does anyone know all the switches and sensors needed for spark? So far I have the kickstand switch bypassed and I don't get spark but the power commander turns on

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #11 of 24 (permalink) Old 06-26-2019, 06:53 PM
My R1 eats me.
 
Join Date: Nov 2018
Posts: 17
You need an 04 service manual. Wiring diagram and Section 8-16 to 8-20 to trouble shoot.

How do I know...I built this with an R1 motor:
https://www.lotustalk.com/forums/f68...-tr1ke-465332/

Also - the green and white plugs are for the fuel pump / tank level sending unit. The brown plug is the rear brake light.
Attached Thumbnails
Click image for larger version

Name:	04wiring.jpg
Views:	11
Size:	313.9 KB
ID:	1000075   Click image for larger version

Name:	04wiringa.JPG
Views:	10
Size:	219.1 KB
ID:	1000077   Click image for larger version

Name:	start.JPG
Views:	10
Size:	184.5 KB
ID:	1000079  

Last edited by dspecgsx; 06-26-2019 at 07:02 PM.
dspecgsx is offline  
post #12 of 24 (permalink) Old 06-26-2019, 07:24 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by dspecgsx View Post
You need an 04 service manual. Wiring diagram and Section 8-16 to 8-20 to trouble shoot.

How do I know...I built this with an R1 motor:
https://www.lotustalk.com/forums/f68...-tr1ke-465332/

Also - the green and white plugs are for the fuel pump / tank level sending unit. The brown plug is the rear brake light.
Thanks for telling me what those connectors were for and yea I have the service manual but seeing wiring diagrams confuse the shit out of me but nice build that thing is seriously sick. The one I'm building is gonna be for the dunes out here in Oregon

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #13 of 24 (permalink) Old 06-26-2019, 07:41 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by dspecgsx View Post
You need an 04 service manual. Wiring diagram and Section 8-16 to 8-20 to trouble shoot.

How do I know...I built this with an R1 motor:
https://www.lotustalk.com/forums/f68...-tr1ke-465332/

Also - the green and white plugs are for the fuel pump / tank level sending unit. The brown plug is the rear brake light.
Success!! I finally got spark. Idk what I did but it has spark now.

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #14 of 24 (permalink) Old 06-26-2019, 10:05 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by Andrew_S View Post
Success!! I finally got spark. Idk what I did but it has spark now.

Sent from my SM-G965U using Tapatalk
Just got it to run by pouring a bit of gas down each intake manifold, thanks for everyone's help


Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #15 of 24 (permalink) Old 06-27-2019, 07:42 AM
para bellum
 
Kangaroo's Avatar
 
Join Date: Apr 2004
Location: Bay Area, CA
Posts: 37,403
Send a message via AIM to Kangaroo Send a message via Yahoo to Kangaroo
:headshake:

This reminds me of the old thread, "Should I get an R1 as a first bike?"

Read the wiring diagram on the service manual. Stare at it long enough and it'll make sense at least in identifying the connectors. The manual will show you the starting circuit to crank the motor. Here on the forum you can search for most of the connectors and setup to get the bike going.

Brothers riding on...
Bandrews 10/11
Dieyoung69 11/10
Vman1300 3/09
Gawarrior 6/08
Elviswarrior 6/07
Crazyclimbr 3/07
K_flexxx 6/06
Kangaroo is offline  
post #16 of 24 (permalink) Old 06-28-2019, 01:30 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by Kangaroo View Post
:headshake:



This reminds me of the old thread, "Should I get an R1 as a first bike?"



Read the wiring diagram on the service manual. Stare at it long enough and it'll make sense at least in identifying the connectors. The manual will show you the starting circuit to crank the motor. Here on the forum you can search for most of the connectors and setup to get the bike going.
Next step is to figure out how to mount this into my gokart frame

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #17 of 24 (permalink) Old 06-30-2019, 08:42 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
How much hp you guys think an 05 r1 can handle? After I get done building the gokart I'm thinking of turboing it trying to make 200whp. Engine has 27k miles

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #18 of 24 (permalink) Old 07-01-2019, 03:34 AM
My R1 eats me.
 
Join Date: Nov 2018
Posts: 17
Quote:
Originally Posted by Andrew_S View Post
How much hp you guys think an 05 r1 can handle? After I get done building the gokart I'm thinking of turboing it trying to make 200whp. Engine has 27k miles

Sent from my SM-G965U using Tapatalk
You should be asking yourself how my HP do you think your frame can handle? Mine can barely handle the HP of the stock motor. Can't keep the rear wheel on the ground for the first 3 gears. At 150 mph the whole front end is skating around like its on ice.
dspecgsx is offline  
post #19 of 24 (permalink) Old 07-01-2019, 03:49 AM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by dspecgsx View Post
You should be asking yourself how my HP do you think your frame can handle? Mine can barely handle the HP of the stock motor. Can't keep the rear wheel on the ground for the first 3 gears. At 150 mph the whole front end is skating around like its on ice.
Well... I did stretch my frame using a harbor freight welder so I honestly don't know if it can even handle 40hp but we will find out and the front end won't be on the ground much as it's for the dunes so it's gonna be constantly wheeling

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
post #20 of 24 (permalink) Old 07-01-2019, 01:41 PM Thread Starter
My R1 eats me.
 
Join Date: Jun 2019
Posts: 14
Quote:
Originally Posted by dspecgsx View Post
You should be asking yourself how my HP do you think your frame can handle? Mine can barely handle the HP of the stock motor. Can't keep the rear wheel on the ground for the first 3 gears. At 150 mph the whole front end is skating around like its on ice.
Actually quick question if I unplug the power commander will the bike still run? Like will the stock ecu control it or is there a stock fuel injection system that plugs into where the power commander plugs in. I've seen videos where you have to splice a wire into your ecu when installing the power commander but mine has 2 big plugs that plug into the harness and that's it

Sent from my SM-G965U using Tapatalk
Andrew_S is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R1 Forum: YZF-R1 Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gixxer kart? Pffft... Has nothing on the r1 kart roki530i Off Topic Talk 1 06-26-2007 10:13 PM
Go!habs Go! Go!habs Go! (keep political BS out of it) martinc Off Topic Talk 40 04-21-2004 09:40 PM
Does anyone Go-kart??? boomhauer General Motorcycle Discussions 6 11-20-2003 10:59 AM
go-kart day's in brisbane Aus. MadDan Local Meets & Events 0 09-23-2003 07:37 PM
R1 Go-Kart fordy Mechanical / Help 31 03-31-2003 07:45 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome