Yamaha R1 Forum: YZF-R1 Forums banner
1 - 8 of 8 Posts

· Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
after changing the battery, blowing/replacing the a couple of fuses (accidently conected the battery backwards), my check engine light is on, with it the traction control automatically turns off and it doesnt let me change the settings, it drives and all just check engine light remains on, if i did it right, the engine code 16, havent found anything online with this code, anyone with any knowledge/suggestions on what to do next?
 

· KaLiFoRniA
Joined
·
95 Posts
From the forum, hope this helps

"Error Code: 15 or 16

Item: Throttle position sensor (open or short circuit) (stuck)

Symptom: Throttle position sensor - open or
short circuit detected.

Fail safe action: Fixes the throttle position sensor to
fully open.

Still able to start and still able to drive.

Possible causes of malfunction:
• Open or short circuit in wiring sub lead.
• Open or short circuit in wiring harness.
• Defective throttle position sensor.
• Malfunction in ECU.
• Improperly installed throttle position sensor."
 

· Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
I haven't had a chance to ride since last week due to weather so i haven't tried any trouble shooting, but is there a reason why when I look up the engine code it starts at 18 and immediately counts down to 16?
 

· Registered
Joined
·
13 Posts
Discussion Starter · #8 ·
So I just found this video, watch the whole thing, I just tried it and hopefully it fixed my problem if not at least I have a better idea on how I can pin point it, and also realized it wasn't code 16 but throttle position lol
Watch "2009 Yamaha R1 Diagnostic Mode DIY" on YouTube
2009 Yamaha R1 Diagnostic Mode DIY: http://youtu.be/UuoZ6JOyr4Y
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top