Yamaha R1 Forum: YZF-R1 Forums banner

421 - 440 of 461 Posts

·
Registered
Joined
·
6 Posts
I

It is helpful to know that but most people have said me to wait for ECU flash... I said to the motorbike mechanics I use, can I just throw a Power Commander on until the ECU flash is out and they told me to wait... that was 6+ months ago! This is getting bloody annoying...

Does anyone know if the lamada sensor disconnection error on the dash can be cleared without the flash?
Have you installed an exhaust where there is no location to install the lambda sensors.
I had that issue and i bought delete plugs that plug into the harness instead of the lambda sensors so you can clear the fault.
 

·
Registered
Joined
·
10 Posts
Have you installed an exhaust where there is no location to install the lambda sensors.
I had that issue and i bought delete plugs that plug into the harness instead of the lambda sensors so you can clear the fault.
I've got the Full Akrapovic system, it does have holes for the lambda sensors. However the guy that installed the exhaust said I wont need to use them, although at that time we thought I was going to be able to flash the ecu, and I assume clear the errors etc...

Im thinking about putting them back in, although I'm also not sure if the error on the dash is related to the exup servo being removed aswell....
 

·
Registered
Joined
·
6 Posts
I've got the Full Akrapovic system, it does have holes for the lambda sensors. However the guy that installed the exhaust said I wont need to use them, although at that time we thought I was going to be able to flash the ecu, and I assume clear the errors etc...

Im thinking about putting them back in, although I'm also not sure if the error on the dash is related to the exup servo being removed aswell....
If you don't connect your lambda sensors you will have a fault which will disable your modes and give you an engine light. You should install your lambda sensors as there is no benefit in having them disconnected while the bike has not been flashed.
You will also have an engine light if you've disconnected the plug from the servo.
 

·
Registered
Joined
·
10 Posts
If you don't connect your lambda sensors you will have a fault which will disable your modes and give you an engine light. You should install your lambda sensors as there is no benefit in having them disconnected while the bike has not been flashed.
You will also have an engine light if you've disconnected the plug from the servo.
Cool, Thanks for the advise.

So will the modes comeback even with the servo unplugged?
 

·
Registered
Joined
·
6 Posts
Cool, Thanks for the advise.

So will the modes comeback even with the servo unplugged?
I'm not sure if the servo fault disables the modes.
You'll have to plug in you lambda sensors and clear the faults with an OBD scanner and see what happens.
If you're modes are still disabling then you'll have to reconnect your servo or buy a servo buddy.

If you need the plugs to bypass the servo and lambda sensors i have them and will sell them on.
I've upgraded to a kit loom and ecu so don't need them any more
 

·
Registered
Joined
·
43 Posts
There is a high chance your engine will fail if you have straight exhaust and no lambdas connected. There was quite a few bikes that blew up with the graves exhaust and with no lambdas connected. Only do that if you have the bike flashed, otherwise the fueling will be even more all over the place..
 

·
Registered
Joined
·
10 Posts
There is a high chance your engine will fail if you have straight exhaust and no lambdas connected. There was quite a few bikes that blew up with the graves exhaust and with no lambdas connected. Only do that if you have the bike flashed, otherwise the fueling will be even more all over the place..
Lamadas are back in and I've plugged a servo buddy in, cleared the errors and the dash is back to normal now... (y)
 

·
Registered
Joined
·
4 Posts
I’ve personally heard a ‘20 with a SC Project slipon and it sounds awesome. I have a ‘19 that I installed the Graves Moto GP slipon and it sounded great.
Did the 2020 just have the SC Project slip on, or slip on with cat delete?

The reason I ask is I have a 2021 with an Akrapovic slip on and I'm really disappointed with how loud it is, or I should say lack there of. Without flashing the ECU I don't want a full system with a cat delete, but on the streets I definitely want to be heard a little more than I am. Is the SC a good way to go in your opinion to make my bike louder without deleting the cat?

I appreciate any feedback, thanks.
 

·
Venom X/O
Joined
·
25,094 Posts
Did the 2020 just have the SC Project slip on, or slip on with cat delete?

The reason I ask is I have a 2021 with an Akrapovic slip on and I'm really disappointed with how loud it is, or I should say lack there of. Without flashing the ECU I don't want a full system with a cat delete, but on the streets I definitely want to be heard a little more than I am. Is the SC a good way to go in your opinion to make my bike louder without deleting the cat?

I appreciate any feedback, thanks.
The sound won’t change without removing the cat
 

·
Registered
Joined
·
314 Posts
Did the 2020 just have the SC Project slip on, or slip on with cat delete?

The reason I ask is I have a 2021 with an Akrapovic slip on and I'm really disappointed with how loud it is, or I should say lack there of. Without flashing the ECU I don't want a full system with a cat delete, but on the streets I definitely want to be heard a little more than I am. Is the SC a good way to go in your opinion to make my bike louder without deleting the cat?

I appreciate any feedback, thanks.
Only the can
 

·
my genius knows no bounds
Joined
·
439 Posts
since theres still no flash yet, why are ppl putting exhausts on their 2020+? i know there are some piggybacks but they dont seem to work well, so aren't people possibly trashing their engines? its something to do with the lower injectors, apparently.
 

·
Registered
2008 r1
Joined
·
738 Posts
since theres still no flash yet, why are ppl putting exhausts on their 2020+? i know there are some piggybacks but they dont seem to work well, so aren't people possibly trashing their engines? its something to do with the lower injectors, apparently.
Akro says it's ok.
 

·
Registered
Joined
·
37 Posts
I'm sure it's safe for the engine under normal street riding with the occasional spinning it up to redline, but I'm not sure how hot that combustion chamber is going to get with long time near red line running. I know there are some on here that may have some insight on that. Myself.. I have a full system sitting in the box waiting to be installed, but my warranty is good until later 2021, so I'm waiting.
 

·
Venom X/O
Joined
·
25,094 Posts
I'm sure it's safe for the engine under normal street riding with the occasional spinning it up to redline, but I'm not sure how hot that combustion chamber is going to get with long time near red line running. I know there are some on here that may have some insight on that. Myself.. I have a full system sitting in the box waiting to be installed, but my warranty is good until later 2021, so I'm waiting.
The ecu is getting the bike to 13 AFR... long term no problem
 
421 - 440 of 461 Posts
Top