Yamaha R1 Forum: YZF-R1 Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hey everyone I have a 2021 yamaha r1 which I've done some work to. The bike is dyno tuned as well. Yesterday after cleaning bike, check engine light on. Rides fine quick shifters no work. I disconnect battery and quickshifter plugs 3 days later..quickshifters work and light is still on. Very frustrated and feel defeated. I don't know where to begin. I've read how to get into self diagnostic mode through the service manual but im not confident in my ability on following all those steps. Was thinking code reader??? Is this a good idea to begin fixing my issue? Is there anyone who had bought a code reader? It says it's obd2. Can I run the code at autozone...???here's my bike all
 

·
Like The Rising Phoenix
Joined
·
2,859 Posts
You can't just plug up a code reader to it. You have to also have the correct adaptor for it to work.
This company sells scanners and adaptors that work. Yamaha ECU Flashing
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #6 ·
"im not confident in my ability on following all those steps" I would take it to a dealer!
Well I do everything to my machine far as I can..figured it to be wet o2 sensor bung that r no longer in use being I'm not running sensors. Silly me didn't use electrical tape and I left wire hanging. Threw a bucket of water at it and gave a short I believe.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #8 ·
Bump. If anyone is interested, that light was due to me getting my unused 02 sensor wet when washing the bike. I taped it up. Had light shut off. Now I have a new problem. I just did new tires and new front pads. I have a SC Light ABS light and check engine light one now. Any ideas??? This bike is great but all these lights are becoming a real hassle. When a light comes on only yamaha can read it and shut it off. This is frustrating as it gets
 

·
Like The Rising Phoenix
Joined
·
2,859 Posts
Bump. If anyone is interested, that light was due to me getting my unused 02 sensor wet when washing the bike. I taped it up. Had light shut off. Now I have a new problem. I just did new tires and new front pads. I have a SC Light ABS light and check engine light one now. Any ideas??? This bike is great but all these lights are becoming a real hassle. When a light comes on only yamaha can read it and shut it off. This is frustrating as it gets
Did you run the bike while it was on the stands? But as far as your lights, I would say something is going on with your slide control or ABS
 
  • Like
Reactions: Buttafewcoe
1 - 9 of 9 Posts
Top