Yamaha R1 Forum: YZF-R1 Forums banner
1 - 5 of 5 Posts

· Full Throttle til you see God
Joined
·
522 Posts
Discussion Starter · #1 ·
Hey guys, just removed clutch cover and while I was holding the linkage to remove the clutch cable suddenly I felt a huge tension release. I finished unbolting the cover and slid it off only to reveal a weird gear type bolt sticking out from the center of the clutch assembly, it just kind of dangles there.... I am getting a new cover tomorrow but I wanted to tear it down to see what I was getting into. When I tried to put the bent cover back on I could never really get that tension back in the linkage. Granted I didnt fully install it but I am sure that the gears were meshing. DId I do something wrong? Hope I explained this good enough, any help is appreciated. Oh, and it's an 04 R1.
 

· Full Throttle til you see God
Joined
·
522 Posts
Discussion Starter · #13 ·
argibson- Yes indeed it did.... you had your rights/lefts confused but that was no big deal, it went together really smoothly. Only snag I hit was that the new cover didnt have a seal or bearing pressed into it and the parts guy didnt think to order them with the cover. I was really pissed seeing as how I paid $60 shipping to have it next day saturday delivery so I could ride this weekend, I would consider that a major oversight. All was well though I just had to drive across town to another dealer who happened to have them in stock. Pressing the bearing in was kinda tricky too just using hand tools but we managed.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top