Yamaha R1 Forum: YZF-R1 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Code 12 on my 2014 R1. Crankshaft position sensor. Traced all wires, replaced sensor, still won't start. Code still pops up. ANY HELP IS APPRECIATED. All love and respect to members here! Ride safe!
 

·
Registered
Joined
·
28 Posts
Mine had the same issue, what caused the code was a bad solenoid starter. The ECU "saw" me pushing the starter button but didn't see the signal from the cs sensor, so it threw a code. I couldn't start the engine with the code and couldn't erase the code. At last, I jumped the starter solenoid and the bike started and the code cleared, it's worth a try if you are sure the timing of the engine isn't messed up.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Mine had the same issue, what caused the code was a bad solenoid starter. The ECU "saw" me pushing the starter button but didn't see the signal from the cs sensor, so it threw a code. I couldn't start the engine with the code and couldn't erase the code. At last, I jumped the starter solenoid and the bike started and the code cleared, it's worth a try if you are sure the timing of the engine isn't messed up.
I also changed the crank chain tensioner and adjusted it. So if I jump the bike thru the solenoid... hopefully the code clears? Wow.... I'll try and let you know. Thanks
 

·
Registered
Joined
·
272 Posts
I also changed the crank chain tensioner and adjusted it. So if I jump the bike thru the solenoid... hopefully the code clears? Wow.... I'll try and let you know. Thanks
I don't think tightening the crank chain tensioner will remove the code. If your chain was loose and jumped a tooth tightening it doesn't make it go back unfortunately.
 
1 - 6 of 6 Posts
Top