Yamaha R1 Forum: YZF-R1 Forums banner

21 - 40 of 51 Posts

·
Wheelies for boobs!
Joined
·
3,992 Posts
In regards to the ECU lag issue. That is totally different. To my knowledge every U.S. model had the problem. If only a few people had reported the lag issue, and everyone else said "no problems with my bike" then there would have been no widespread Exchange Notice and everyone would have just assumed that there were a few bikes with this problem.

As an example, some members have reported footrest snapping off. Does this mean that every footrest on every R1 is going to snap off? Does this mean that every R1 owner should run out and purchase aftermarket rearsets because a few have had them snap off? I would hope the answer to both would be no.

If you remember, when the lag issue was first posted here and for a good time afterwards, there were many US people who said that they didn't have the problem. Even after the majority of us agreed that every US bike should have. Everyone who has a US 07 R1 has a US 07 R1 and it still took 6 months of posts, phone calls, dealer complaints, NHSTA claims, etc. for Yamaha to recognize there is a problem with their product. Not everyone who has a US 07 R1 has a SpeedoHealer and even if they did and there was a problem I doubt the manufacturer would go on record and say/do something about it. Maybe that was a poor example, but I'm sticking to it! :chair:

The footrest issue is much more apparent. Unfortunately all you have to do is look at the right footrest and say hey that don't look right WTF? And there is a significant history with Yamaha's pegs. The 02 had shitty ones (I broke 2 and posted that up way back then, replaced with Vortex) the 04 actually was advertised as having improved footrests on Yamaha's website when it came out (but I didn't trust them and I replaced them with Gilles,) and the 07 has the "notch" so they got replaced with Satos. I wish every R1 owner should not have to run out and purchase aftermarket rearsets because a few have had them snap off as well, but as far as I'm concerned if it happens to you then what does it matter what the odds are?

Hey, what was the topic of this thread again? :eek:

I think we can agree to disagree, ok?
 

·
STRAIGHT ROADS SUCK!
Joined
·
1,492 Posts
If you remember, when the lag issue was first posted here and for a good time afterwards, there were many US people who said that they didn't have the problem. Even after the majority of us agreed that every US bike should have. Everyone who has a US 07 R1 has a US 07 R1 and it still took 6 months of posts, phone calls, dealer complaints, NHSTA claims, etc. for Yamaha to recognize there is a problem with their product. Not everyone who has a US 07 R1 has a SpeedoHealer and even if they did and there was a problem I doubt the manufacturer would go on record and say/do something about it. Maybe that was a poor example, but I'm sticking to it! :chair:

The footrest issue is much more apparent. Unfortunately all you have to do is look at the right footrest and say hey that don't look right WTF? And there is a significant history with Yamaha's pegs. The 02 had shitty ones (I broke 2 and posted that up way back then, replaced with Vortex) the 04 actually was advertised as having improved footrests on Yamaha's website when it came out (but I didn't trust them and I replaced them with Gilles,) and the 07 has the "notch" so they got replaced with Satos. I wish every R1 owner should not have to run out and purchase aftermarket rearsets because a few have had them snap off as well, but as far as I'm concerned if it happens to you then what does it matter what the odds are?

Hey, what was the topic of this thread again? :eek:

I think we can agree to disagree, ok?
Well it started out as a TRE thread and quickly turned into a Speedohealer thread. Somewhere thru providing examples to each other, we managed to turn it into an ECU/LAG and snapping footrest thread.:hammer:

We can agree to disagree if you wish.

However, if you continue to post that the Speedohealer affects all 07 R1's performance, I will continue to dispute the fact that not all are affected, so we will continue to have this conflict over and over forever. (well at least until the 09 R1 comes out) :sissy: :lol :lol

That being said, you could save me a lot of time by just posting an accurate description of both sides of the issue to begin with.:bow

I will stop now.

Ride safe.
 

·
Ghostrider Squadron
Joined
·
9,251 Posts
Re-gearing doesn't affect the relationship between indicated speed and rpm, just actual speed vs. rpm.

The ECU definitely looks at the speed input. The throttle lag recall/issue /whatever all centered around 2nd gear and a speed, not rpm. I found that out when I had my SpeedoHealer installed.
really.. the ones i have seen all did it at certain RPM... not to argue with you. even ones regeared still had problem at same rpm. i even thought the yamaha bulletin specifies the rpm and not speed... again not arguing, just saying what i what led to believe. i can go pull yamaha bulletin off our YDS system and see what it says. but if ur speedohealer effected it, the it would have to be speed sensitive.
 

·
Registered
Joined
·
106 Posts
did any1 experience what i've noticed??! The limiter comes in a LITTLE earlier in sixth gear. If there's no TRE available for the 07R1, is there another solution? sum1 said that a speedo healer might help cos the ecu reads the speed thus the limiter comes in??? any help/advice??!!
 

·
Ghostrider Squadron
Joined
·
9,251 Posts
are u sure its rev limiter in 6th?? is it different rpm than rev limiter in other gears?? i do know tachs are off in bike to bike.. some off little, some more than others. my wide band shows mine stopping at 13800 but tach will show like 14200. is ur bike regeared?? pipe or anything?? stock bike with stock gearing just wont pull revlmiter in 6th gear.. it just quits pulling.
 

·
R1-014 Dragon Squadron
Joined
·
539 Posts
Any idea on how much they charge for that?

EDIT: $549 with a 2 day turn-around

Hmm.. Very tempting.. After I get wheels and tires for my truck I think I might have to give them a call.. Early next year I may be making the bike even more awesome..
 

·
Wheelies for boobs!
Joined
·
3,992 Posts
Any idea on how much they charge for that?

EDIT: $549 with a 2 day turn-around

Hmm.. Very tempting.. After I get wheels and tires for my truck I think I might have to give them a call.. Early next year I may be making the bike even more awesome..

Save your money and take a race class...
 

·
R1-014 Dragon Squadron
Joined
·
539 Posts
lol..

I'm getting frustrated about the limitations on the bike.. I've put up with it for 3 years now.. It's either get the ecu flashed or jump ship to an Aprilla. =)
 

·
Wheelies for boobs!
Joined
·
3,992 Posts
lol..

I'm getting frustrated about the limitations on the bike.. I've put up with it for 3 years now.. It's either get the ecu flashed or jump ship to an Aprilla. =)

But what is so limiting? Hell I still have mine (and it's been paid off for nearly a year) because there's nothing out there that's worth spending more money on. Incremental improvements at best...
 

·
R1-014 Dragon Squadron
Joined
·
539 Posts
It's hard to explain I guess..

If I'm in my lower gears and smash the throttle it's unpredictable.. It's like "turbo lag" My 02 R1 was smooth all the way through.. Not a hesitation/bog then a violent release of power..

A lot of the reading I've done says it has to do with the ecu being limited from the factory.
 

·
Wheelies for boobs!
Joined
·
3,992 Posts
It's hard to explain I guess..

If I'm in my lower gears and smash the throttle it's unpredictable.. It's like "turbo lag" My 02 R1 was smooth all the way through.. Not a hesitation/bog then a violent release of power..

A lot of the reading I've done says it has to do with the ecu being limited from the factory.
I had an 02 and a 04 and both had way better throttle response than my 07. Personally, I think it's because of the YCC-T so maybe there is a way to accelerate the process through the ECU... Though I like my solution better... 16/48 sprockets.
 

·
R1-014 Dragon Squadron
Joined
·
539 Posts
I had an 02 and a 04 and both had way better throttle response than my 07. Personally, I think it's because of the YCC-T so maybe there is a way to accelerate the process through the ECU... Though I like my solution better... 16/48 sprockets.

Atleast you understand the throttle response issue...

ECU/YCC-T either way I think the flash would fix it..

As for sprockets.. I did go -1 in the front.. Haven't decided if I want to change the rear yet.. I always say I don't want to give up top speed, but in the 3 years I've had the bike I have never had the speedo above 154, and even then I know it was wrong cause I already went -1 in the front and no speedo healer.
 
21 - 40 of 51 Posts
Top