Yamaha R1 Forum: YZF-R1 Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
400 Posts
Discussion Starter · #2 ·
Installed... Note these are a hell of alot harder to install than the factory ones. Maybe it was just my set but the factory bolts with washers were binding inside the holes machined for them... Needless to say I got them in but its tough when you don't know if the bolt is tight because of the fit or if its cross threaded in the housing. And make sure you use locktite in the future because they don't have the "safety" clip to hold the bolts in like the factory ones. They seemed quite heavy also. I wonder how light the graves ones are?
 

Attachments

· Registered
Joined
·
400 Posts
Discussion Starter · #4 ·
They were anodized from factory pro themself.... I called and at the time that was the only set they had available. The part that the bolts were binding with was the bare alluminum bracket. The anodized tubes fit nice but the bolts were tight turning in the bracket without even attaching it to anything. It's very possible it was just my set.
 

· Registered
Joined
·
400 Posts
Discussion Starter · #11 ·
LOL why not blue or green to match the water, or red if you have water wetter? No seriously i know you can't see them but thats what you get if you order from factory pro and say you want black anodized... no extra cost
 

· Registered
Joined
·
400 Posts
Discussion Starter · #29 ·
Yup yup... mid range NICE now... girgle gone... :) me soooo happy... But anyways either stacks are good in my oppinion, but since I had specific issues with my mid-range I went with the factory pro.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top