Yamaha R1 Forum: YZF-R1 Forums banner
1 - 17 of 17 Posts

·
2015 Yamaha R1
Joined
·
126 Posts
Discussion Starter · #1 ·
Ive seen it before and it was very complex but I can't seem to find the info anyway. Does someone have a link to this and a set of codes showing what the numbers are. I've looked in my service manual and I couldn't find anything. Does anyone know if there is a way to clear the code from the ECU aswell. Thanks in advance.
 

·
Premium Member
Joined
·
262 Posts
Real quick question guys. How do I enter the diag mode? Currently not at home, and have just removed the EXUP. Bike is flashed with " diasable exup trubble recall" set to "true", but I still get code 17. Anyone please?
 

·
Registered
Joined
·
39 Posts
Real quick question guys. How do I enter the diag mode? Currently not at home, and have just removed the EXUP. Bike is flashed with " diasable exup trubble recall" set to "true", but I still get code 17. Anyone please?
How do you know its a 17 if you don't know how To enters diag mode?

Do the codes show regardless of whether you are in diagnostic mode?
 

·
Premium Member
Joined
·
262 Posts
Real quick question guys. How do I enter the diag mode? Currently not at home, and have just removed the EXUP. Bike is flashed with " diasable exup trubble recall" set to "true", but I still get code 17. Anyone please?
How do you know its a 17 if you don't know how To enters diag mode?

Do the codes show regardless of whether you are in diagnostic mode?
Yes they do. I Still dont know how to access diag mode. .
 

·
Administrator
Joined
·
25,086 Posts
The 2nd post in this thread gives you pictures of the service manual detailing how to enter diagnostic mode. :fact
 

·
Premium Member
Joined
·
262 Posts
The 2nd post in this thread gives you pictures of the service manual detailing how to enter diagnostic mode. :fact
Ok.. Then what the heck am I missing or not seeing here :S ?

2nd post only explains the different codes as I see it ?
Not how to enter diag mode, like in the 09-14 R1.. Or ?? :serious:
 

·
MonkeyMan #413
Joined
·
226 Posts
Soooo....I got my R1 back from recent dyno testing and apparently my tuner forgot to set dyno mode in FlashTune. Now the R1 is stuck with error code 42 and 69. I've entered diagnostic mode and viewed 62 and it showed 02 for the code (because of above errors). However, when I rocked the run/start switch to ON the fuel pump charges but the errors don't clear. I've tried a few different things and even started the bike (while still in diagnostics) to see if that changed anything but no luck.

What am I missing here? Is there another step after setting diag to 62 and seeing the # of codes listed to clear them (aside to or in addition to rocking the run/start switch towards start)?

Thx
 

·
Registered
Joined
·
63 Posts
For 2015 & 2016 models:

1. Hold both Mode and upward motion button on left clipon simultaneously while turning key from off to on position. Hold for 8 seconds. ECU image will appear on display.
2. Repeat, press both buttons for 8 seconds until DIAG appears on screen.
3. Repeat, press both buttons until DIAG Code number and message count number appear on screen.
4. Select DIAG code by pressing upward motion key until desired error code is displayed.
5. All error codes can be deleted by selecting code 63. Error codes are displayed. clear by pressing Red start / stop switch on right clipon off then on.
6. Turn key to off position. All error codes are now deleted.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top