Yamaha R1 Forum: YZF-R1 Forums banner

1 - 20 of 28 Posts

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #1
My problem, my guages, headlights, turn signals no worky. I have checked all my fuses under the seat, loked for loose connections or broken wiring and could not find anythng. On my guages, my lower lights work though (neutral light, etc.) Is there anything that I need to check that controls all these functions. My manual is on my other computer and I don't have access to it right now (left it at work). Everything went dead yesterday, the tach started to blink out at times while riding then, whe nI shut the bike down at one of my stops then started it back up about 45 minutes later nothing was working. Any help qould be nice. Thanks.

:dunno
 

·
Off Topic mod
Joined
·
11,217 Posts
Have you done anything to the bike recently? If your 98 is like my 02, all the connection for the spedo, headlight and such are on the left innner portion of the faring. I take it you cheked those right?
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #3
yeah they are on the left too, I did check those. I didn't do anythng to the bike as far as electrically or neding to take that section apart. The only thing that I saw was that whoever had the bike b4 me after he had the bike painted he used alot of electrical tape to tie the wires up. I pulled the tape off to look but everything looked ok.
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #5
Also, the wiring assebly from the front plugs into a black box under the seat towards the rear. Without a manual, I did not know what this box was. Tomorrow I will have the other computer with me, all my tools, and meters for testing.

BTW, my baby is in the garage now and naked as a Jay Bird. Makes me feel sad when I see her in that condition.
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #7
FastAznR1 said:
Have you checked your voltate regulator?
Nope, not yet. Did not think of that. I will check that tomorrow though. Going to bed here real soon.

Thanks man.....:thumbup
 

·
Registered
Joined
·
8,571 Posts
No problemo, I only suggested that because my R1 did allthose
very same thing. I think the part was like $70 or so + tax and the
bike has been runnign like a champ!
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #10
FastAznR1 said:
I think the part was like $70 or so + tax and the
bike has been runnign like a champ!
Cheap repair if that is the problem.. I like cheap repairs.
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #13
Well I figured it out. It is the regulator.. :) Helps when you have the manual.. Now I need to find one. Let's see how long that takes.
 

·
Registered
Joined
·
8,571 Posts
ay yah, for a R1? I had to special order mines. Give a call to
powersports down in Cutler Ridge, or the one by I95 North above
I595... lemme get my file and I'll repply w/a #
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #16
big blue said:
hey ya in luck I got one in the garage. make an offer....
Thanks. Let me call around locally to see if I can get a hold of one today, If not I will at least know what they cost new and I will make you an offer. Thanks again.
 

·
Registered
Joined
·
8,571 Posts
I just called Powersports of Hollywood (i assume its close to you?)

They told me they don't have the part but they can get it within
3-5 days. The part is $56.60 + tax. I asked him if he can get it
faster he goes ye sfor additional s&h.

Call Sean @ Powersports of Hollywood
2811 Evans Street
Hollywood, FL 33020

954-921-4121 (Parts department)
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #19
mxracer95 said:
What makes you think it's the regulator?

Well I thought that it was the regulator, but now I don't think it is. The reason was that when I unplugged the regualtor the bike symptoms stayed the same nothing worse. So I went and bought a regulator at this other place, $130.00, still have the same problem. Either it still is the regualtor for reason that the part numbers don't match but are Yamaha parts, or it is something else. Running out of ideas, I think it is time for the shop.
 

·
I hate the rain
Joined
·
278 Posts
Discussion Starter #20
Just found out that the regulator I bought is for the newer R1's. So now I am going to order the ONE that I need. This is what happens when you go shopping in Opa-Locka!!!
 
1 - 20 of 28 Posts
Top