Yamaha R1 Forum: YZF-R1 Forums banner

1 - 18 of 18 Posts

·
I EAT MY R1
Joined
·
36 Posts
Discussion Starter #1
ok i put it in neutral and the light wont come on, i go to start the bike but it wont start. i put the kick stand up and it starts while its running i put the kickstand down and it shuts the engine off like is should if its in gear. if i rev the engine really high the neutral light will flicker a bit, so my question is where should i be looking to solve my issue
 

·
Registered
Joined
·
12 Posts
ok i put it in neutral and the light wont come on, i go to start the bike but it wont start. i put the kick stand up and it starts while its running i put the kickstand down and it shuts the engine off like is should if its in gear. if i rev the engine really high the neutral light will flicker a bit, so my question is where should i be looking to solve my issue
I would start be checking connections on your neutral safety switch.
 

·
I EAT MY R1
Joined
·
36 Posts
Discussion Starter #5
no the neutral the light wont come on, i go to start the bike but it wont start. i put the kick stand up and it starts while its running i put the kickstand down and it shuts the engine off like is should if its in gear. if i rev the engine really high the neutral light flickers
 

·
I EAT MY R1
Joined
·
36 Posts
Discussion Starter #7
yea thats what i thought but like i said im not sure where else to look. what is the neutral light on the tach hooked up to and what would cause the light to not come on besides a bad connection and if it is a bad connection where do i go to check
 

·
Registered
Joined
·
2 Posts
I got the same on my '02.
For sure on mine is it the neutral switch, tested with a multimeter.

It can be also the starting cut off relay, but if it flickers, could be a bad connection on the wires, but also, I guess there is a pin which push the neutral switch in the gearbox.
Try to remove it, and push it manuallly and check if light comes up.
 

·
Only 1 R1
Joined
·
330 Posts
@OP. Not sure about neutral light but kick stand seems to be a good feature for me. I almost tripped on high side once coz of kick stand. Wish I had the auto shutoff.
 

·
I EAT MY R1
Joined
·
36 Posts
Discussion Starter #11
so your saying take the switch out and then in that hole there should be a pin or do you mean the pin on the switch its self. and if you mean the pin on the switch then yes it works but might be a little weak
 

·
Registered
Joined
·
2 Posts
I'm saying there must be something IN the gearbox which push the button.

By pressing manualy you switch when it is out, you're testing the whole system, if the light comes up correctly by pushing it manually, then it must be something related with the thing which push the neutrql switch (inside the gearbox) or maybe your gasket is not enough thin?

If not, it must be something related with wires on the Cut-off relay or the cut-off relay itself.

For sure, nothing related for the neutral light, otherwise your bike would start.

Look at this document, it shows how the starting works on a 2003 R1.
 

Attachments

·
I EAT MY R1
Joined
·
36 Posts
Discussion Starter #13
cool im going to think about replacing the hole clutch and stuff so that way if i go in to take a look i have a good reason to.
 

·
Is there anybody out there?
Joined
·
3,993 Posts
I'm with Francky93, pull the switch out and push it manually. Don't forget to ground the threads on the switch or it won't work. If the light works, you have a physical problem in your gear box. If it doesn't, get yourself a copy of the service manual and a multimeter and start checking continuity.

Mark
99 R1

ps The clutch has nothing to do with the neutral switch so I wouldn't waste my time replacing it.
 

·
Registered
Joined
·
1 Posts
ok i put it in neutral and the light wont come on, i go to start the bike but it wont start. i put the kick stand up and it starts while its running i put the kickstand down and it shuts the engine off like is should if its in gear. if i rev the engine really high the neutral light will flicker a bit, so my question is where should i be looking to solve my issue
same thing happened to my ninja 250r 2011, (except for the flickering light, didn't test that) but i left it alone for a couple of days and low and behold the problem fixed itself, just when i made an appointment at the shop!
 

·
Registered
Joined
·
7 Posts
Neutral light was not on and bike would cut off

I had the same problem on my 2001 r1, it was the wire that connects to the back of the engine was lose so I disconnected and plugged it back up and the bike started fine with no problems
 

·
Yamaha 4 life
Joined
·
9 Posts
Hey everyone,

What ended up being the issue. I have the same problem. My 2001 Yamaha R1 neutral light won't come on until the kick stand is up. However, when I start the bike and drive. The neutral light stays on no matter what gear I am in. When I'm done driving-if I put the kick stand down it turns the bike off (even in neutral). I checked the switch and its fine. I checked continuity and its fine. I checked the connections and they seem fine. I checked to see if something was hooked up wrong and everything seems fine. I think I'm over looking something silly. I even had the shop look at it and from a few basic tests no one seems to know whats wrong. I think everything is hooked up right. If anyone has any advice please let me know.
 
1 - 18 of 18 Posts
Top