Yamaha R1 Forum: YZF-R1 Forums banner

1 - 16 of 16 Posts

·
When in doubt pin it!!
Joined
·
13 Posts
Discussion Starter #1
Hey guys, long story short. i just bought a 98 R1 but it has a 2000 R1 engine put in. the guy said he used the carbs off the 98 with the 2000. it sputters and lacks power mostly at midrange rpm but sometimes right down to 3000rpm. sometimes it's not there. any suggestions as to what it might be? i suspect the carbs. shouldn't they have to be set up or jetted or something?
 

·
wanna B on the Track
Joined
·
1,150 Posts
why did he change out the engine..?? my 98 has 55000 miles on it, 500 of that was this weekend .. and i feel no need to do an engine change.
 

·
When in doubt pin it!!
Joined
·
13 Posts
Discussion Starter #4
the guy blew the engine on the track. then he replaced it with a 2000 eng. holy f this sounds like it could be expensive to straighten out.
 

·
Banned
Joined
·
9,594 Posts
R1NEWFIE said:
the guy blew the engine on the track. then he replaced it with a 2000 eng. holy f this sounds like it could be expensive to straighten out.
Once again, my question is this:

Did they also replace the ECU?? If not, then you have problems.
 

·
PWN3R
Joined
·
1,396 Posts
I don't think you can run newer engine with older ECU.
Correct me if im wrong
 

·
Cornering Enthusiast
Joined
·
1,747 Posts
castrolr1 said:
why did he change out the engine..?? my 98 has 55000 miles on it, 500 of that was this weekend .. and i feel no need to do an engine change.
55k??!!!
:bow :bow :bow

I've only got a lowly 34k.......:lol Then again my bike is an '02....LOL
 

·
Registered
Joined
·
14,085 Posts
I dont see why the 00 ECU wouldnt work with the 98 carbs...they are the same except for a couple of minor things.

Only elect. thing on them is the TPS and they are the same on all.

Maybe your problems lies in dirty carbs or dirty air filter or dead spark plugs;

My only advice before letting go to the ECU paranoia (lol) would be to take off the carbs and clean them and inspect every little holes in every little parts for dirt or partial clogging.

Inspect the airfilter;if its dirty,discard and put a new stock one.

In spect the plugs;hell,forget about inspecting them;replace them,but dont attempt at starting the bike with them before checking the 2 other things.
 

·
When in doubt pin it!!
Joined
·
13 Posts
Discussion Starter #10
ok thanks guys for the suggestions. i'll call the guy i bought it off tonight. the bike has 37000km's (canada) and the 2000 engine he put in had 8000 km's on it. i am going to change filter,plugs etc this weekend. if that doesn't work i'll have to have a mechanic look at the carbs. i hope it's not the ecu, i'll keep you updated.
 

·
When in doubt pin it!!
Joined
·
13 Posts
Discussion Starter #11
btw, i don't know how old the fuel was in the bike but i burned 3 tanks of premium gas this past weekend.
 

·
Banned
Joined
·
9,594 Posts
martinc said:
I dont see why the 00 ECU wouldnt work with the 98 carbs...they are the same except for a couple of minor things.

Only elect. thing on them is the TPS and they are the same on all.

My only advice before letting go to the ECU paranoia (lol) would be to take off the carbs and clean them and inspect every little holes in every little parts for dirt or partial clogging.
What I'm saying is that I don't think the 1998 wiring harness and ECU will mate with the 2000 engine. So rather than cleaning the carbs and doing other work you may not have to have done. Simply check with Yamaha to see if that 2000 engine will function with the 1998 ECU. If not, problem solved. And he did not even get his fingers dirty. :thumbup
 

·
see you at the races and ride
Joined
·
3,906 Posts
does it have the exup on it?pull all the plugsto check if one is fouled .R1s will blubber from dirty air jets and sticky float valves, both will show on a plug.
 

·
When in doubt pin it!!
Joined
·
13 Posts
Discussion Starter #15
thanks guys. i talked to the guy last night. the ecu is from the 98, it all plugged together fine and ran fine. he did the swap a year ago and he didn't have any problems. he used the bike on the track and the street, this thing would be terrible on the track the way it's running now. it still has the EXUP. it has a K&N filter. He thinks it might be dirty carbs or the EXUP is malfunctioning? Make sense? i will check the plugs tonight.
 
1 - 16 of 16 Posts
Top